Софт-Портал

Cisco Vpn клиент

Рейтинг: 4.8/5.0 (345 проголосовавших)

Категория: Mac

Описание

Cisco VPN Client 32


Cisco VPN Client - это специальное сетевое ПО, которое используется для создания IPSec-туннеля с серверами Cisco Easy VPN. В качестве которых могут выступать Cisco VPN 3000 Concentrator, Cisco PIX, Cisco ASA 5500 и Cisco IOS.

Simple to deploy and operate, the Cisco VPN Client allows organizations to establish end-to-end, encrypted VPN tunnels for secure connectivity for mobile employees or teleworkers. This thin design, IP security (IPSec) implementation is compatible with all Cisco virtual private network (VPN) products.

The Cisco VPN Client can be preconfigured for mass deployments, and initial logins require little user intervention. It supports the innovative Cisco Easy VPN capabilities, delivering a uniquely scalable, cost-effective, and easy-to-manage remote access VPN architecture that eliminates the operational costs associated with maintaining a consistent policy and key management method. The Cisco Easy VPN feature allows the Cisco VPN Client to receive network security policies upon a VPN tunnel connection from the central site VPN device (Cisco Easy VPN Server), minimizing configuration requirements at the remote location. This simple and highly scalable solution is ideal for large remote access deployments where it is impractical to individually configure policies for multiple remote PCs.

The Cisco VPN client supports Windows 2000, XP and Vista (x86/32-bit only); Linux (Intel); Mac OS X 10.4; and Solaris UltraSparc (32 and 64-bit). For x64 (64-bit) Windows support, you must utilize Cisco's next-generation Cisco AnyConnect VPN Client. The Cisco VPN Client is compatible with the following Cisco products:
Cisco 6500 / 7600 IPSec VPNSM and VPN SPA IOS Software Release 12.2SX and later
Cisco VPN 3000 Series Concentrator Software Version 3.0 and later
Cisco IOS Software Release 12.2(8)T and later
Cisco PIX Security Appliance Software Version 6.0 and later
Cisco ASA 5500 Series Software Version 7.0 and higher

The Cisco VPN Client is included with all models of Cisco ASA 5500 Series Security Appliances(excluding ASA 5505). Customers with Cisco SMARTnet® support contracts and encryption entitlement may download the Cisco VPN Client from the Cisco Software Center at no additional cost. For customers without Cisco SMARTnet support contracts, a media CD containing the client software is available for purchase. This CD does not provide access to the most current patch releases.

Скачать бесплатно Cisco VPN Client v5.0.07.0290 32/64 bit

Cisco vpn клиент:

  • скачать
  • скачать
  • Другие статьи, обзоры программ, новости

    Cisco VPN Client и default Gateway - Форум WindowsFAQ

    Аналогичная проблема, только клиент не Cisco VPN Client, а F5 (www.f5.com ).
    В этом клиенте нет похожей настройки. Так-же напрочь переопределяет дефолтный шлюз.
    Входные данные:
    1. Комп с VPN-клиентом 192.168.0.24
    2. Локалка 192.168.0.0 mask 255.255.255.0 с дефолтным шлюзом 192.168.0.1
    3. Хочется доступ в локальную сеть при поднятом VPN.

    Без VPN:
    ===========================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric
    0.0.0.0 0.0.0.0 192.168.0.1 192.168.0.24 25
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    169.254.0.0 255.255.0.0 192.168.0.24 192.168.0.24 30
    192.168.0.0 255.255.255.0 192.168.0.1 192.168.0.24 1
    192.168.0.0 255.255.255.0 192.168.0.24 192.168.0.24 1
    192.168.0.24 255.255.255.255 127.0.0.1 127.0.0.1 25
    192.168.0.255 255.255.255.255 192.168.0.24 192.168.0.24 25
    224.0.0.0 240.0.0.0 192.168.0.24 192.168.0.24 25
    255.255.255.255 255.255.255.255 192.168.0.24 3 1
    255.255.255.255 255.255.255.255 192.168.0.24 192.168.0.24 1
    Default Gateway: 192.168.0.1
    ===========================================================================
    Persistent Routes:
    None

    С VPN:
    ===========================================================================
    Active Routes:
    Network Destination Netmask Gateway Interface Metric
    0.0.0.0 0.0.0.0 10.7.98.224 10.7.98.224 1
    10.7.96.1 255.255.255.255 10.7.98.224 10.7.98.224 1
    10.7.98.224 255.255.255.255 127.0.0.1 127.0.0.1 50
    10.255.255.255 255.255.255.255 10.7.98.224 10.7.98.224 50
    127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
    169.145.2.17 255.255.255.255 192.168.0.1 192.168.0.24 1
    192.168.0.24 255.255.255.255 127.0.0.1 127.0.0.1 25
    192.168.0.255 255.255.255.255 192.168.0.24 192.168.0.24 25
    224.0.0.0 240.0.0.0 10.7.98.224 10.7.98.224 50
    224.0.0.0 240.0.0.0 192.168.0.24 192.168.0.24 25
    255.255.255.255 255.255.255.255 10.7.98.224 10.7.98.224 1
    255.255.255.255 255.255.255.255 192.168.0.24 3 1
    255.255.255.255 255.255.255.255 192.168.0.24 192.168.0.24 1
    Default Gateway: 10.7.98.224
    ===========================================================================
    Persistent Routes:
    None

    Пробовал делать ROUTE ADD 192.168.0.0 MASK 255.255.255.0 192.168.0.24 - не помогает!

    ЗЫ: К настройкам VPN-сервера доступа не имею

    Регистрация: сен 2002

    Сообщений: 10 611

    ROUTE ADD 192.168.0.0 MASK 255.255.255.0 192.168.0.1 -p

    Страница 1 из 3

    Сохранить ссылку на эту тему у себя в

    Активное сетевое оборудование

    Активное сетевое оборудование

    Активное сетевое оборудование

    Серверное программное обеспечение

    Операционные системы Microsoft Windows

    Время 23:14. Временной пояс GMT +4.

    Ошибка соединения Cisco VPN Client (Error

    IT. notes Ошибка соединения Cisco VPN Client (Error/Reason Messages List)

    Путь: It.notes > Cisco > Ошибка соединения Cisco VPN Client (Error/Reason Messages List)

    Reason 401: An unrecognized error occurred while establishing the VPN connection.

    Troubleshooting: VPN connection was not established because of an unrecognized reason. Please check client logs for details.

    Reason 402: The Connection Manager was unable to read the connection entry, or the connection entry has missing or incorrect information.

    Troubleshooting:Either the connection profile is missing or does not have all the information. To fix this problem, you can either select another connection profile, or fix the current connection entry. Connection profiles are located in profiles. On most machines, this is "C:Program FilesCisco SystemsVPN Clientprofiles". To fix this problem, replace the connection profile file from the profiles directory. This file can be copied from a machine that has the correct entry of this file.

    Reason 403: Unable to contact the security gateway.

    Troubleshooting: This can happen because of multiple reasons. One of the reasons that users can get this message is because IKE negotiations failed. Check the client logs for details.

    Reason 404: The remote peer terminated the connection during negotiation of security policies.

    Troubleshooting: Check the remote peer (head?end) logs to determine the cause for this failure. connection during negotiation of security policies.

    Reason 405: The remote peer terminated connection during user authentication.

    Troubleshooting: This reason is not currently used.

    Reason 406: Unable to establish a secure communication channel.

    Troubleshooting: This reason is not currently used.

    Reason 407: User authentication was cancelled by the user.

    Troubleshooting: A user hit the cancel button (instead of OK) in the VPN Client user authentication dialog.

    Reason 408: A VPN connection is already in the process of being established.

    Troubleshooting: A connection is already in process.

    Reason 409: A VPN connection already exists.

    Troubleshooting: A VPN connection already exists.

    Reason 410: The Connection Manager was unable to forward the user authentication request.

    Troubleshooting: This is not currently used.

    Reason 411: The remote peer does not support the required VPN Client protocol.

    Troubleshooting:The remote peer is either not a Cisco device or it does not support the VPN Client protocol specification.

    Reason 412: The remote peer is no longer responding.

    1. In many cases, this is due to loss of connectivity. Make sure you can ping the remote peer, or check remote peer logs for why it is not responding to the client.

    2. If you have your firewall turned on, there might be a rule that is preventing the connection from being established properly. Disable your firewall and try again.

    3. Please make sure the group name is exactly as the same as the VPN server group name.

    4. Try disabling any firewall software on your PC.

    5. Setting your MTU to 1300 or lower will prevent packets from being fragmented and therefore increase performance. To do that, go to the Start > All Programs > Cisco Systems VPN Client > Set MTU.

    Reason 413: User authentication failed.

    Troubleshooting:Either the user entered wrong user authentication information, or the client was not able to launch the XAuth (user authentication) process.

    Reason 414: Failed to establish a TCP

    Troubleshooting:The VPN Client was not able to establish the TCP connection for IPSec over TCP connection mode. Please try IPSec over UDP or straight IPSec. Please look at client logs for details.

    Reason 415:A required component PPPTool.exe is not present among the installed client software.

    Troubleshooting:Please make sure that ppptool.exe is present in the client installation directory (this is generally C:Program FilesCisco SystemsVPN Client. If this file is not present, uninstall and reinstall the client.

    Reason 416: Remote peer is load balancing.

    Troubleshooting: The peer has advised you to use a different gateway.

    Reason 417: The required firewall software is no longer running.

    Troubleshooting: The required firewall is not running.

    Reason 418: Unable to configure the firewall software.

    Troubleshooting: The peer sent an unrecognized firewall message.

    Reason 419: No connection exists. This is an unexpected error.

    Troubleshooting: Please check client logs for details.

    Reason 420: The application was unable to allocate some system resources and cannot proceed.

    Troubleshooting: The system ran out of memory. If you think the system has enough memory, reboot the machine and try again.

    Reason 421: Failed to establish a connection to your ISP.

    Troubleshooting:Failed to establish a dialup connection. View the client logs for details.

    Reason 422: Lost contact with the security gateway.

    Troubleshooting: Check your network connection. The machine's IP address changed or the machine is no longer connected to the Internet.

    Note: The VPN Client is required to disconnect the VPN tunnel for security reasons, if the machines IP Address has changed.

    Reason 423: Your VPN connection has been terminated.

    Troubleshooting: Either the user disconnected the VPN tunnel, or there was an unexpected error.

    Reason 424: Connectivity to Client Lost by Peer.

    Troubleshooting: Connection disconnected by the peer. Check the peer logs for details.

    Reason 425: Manually Disconnected by Administrator.

    Troubleshooting: Administrator manually disconnected the VPN tunnel.

    Reason 426: Maximum Configured Lifetime Exceeded.

    Troubleshooting: The VPN Client exceeded the maximum configured lifetime for a session. This value is configured on the peer (head?end) device.

    Reason 427: Unknown Error Occurred at Peer.

    Troubleshooting: Peer disconnected tunnel. Check the peer logs for details.

    Reason 428: Peer has been Shut Down.

    Troubleshooting: Peer was shut down.

    Reason 429: Unknown Severe Error Occurred at Peer.

    Troubleshooting: Check the peer logs for details.

    Reason 430: Configured Maximum Connection Time Exceeded.

    Troubleshooting: VPN Client has been connected for longer than allowed by the peer.

    Reason 431: Configured Maximum Idle Time for Session Exceeded.

    Troubleshooting: The VPN connection was idle for longer than the time allowed by the administrator.

    Reason 432: Peer has been Rebooted.

    Troubleshooting: The peer has been rebooted.

    Reason 433: Reason Not Specified by Peer.

    Troubleshooting: The peer gave no reason for disconnecting the tunnel.

    Troubleshooting: In many cases, the VPN disconnect the connection. Check the peer logs for details.

    Reason 434: Policy Negotiation Failed.

    Troubleshooting: Client and peer policies do not match. Try changing peer policies (try using 3DES, AES, and so forth) and then try again.

    Reason 435: Firewall Policy Mismatch.

    Troubleshooting: Firewall policies do not match with what was configured by the peer.

    Reason 436: Certificates used have Expired.

    Troubleshooting: The certificate used in the connection profile has expired. Update the certificate configured in the client profile, and then try again.

    Reason 442: Failed to enable Virtual Adapter.

    Эта страница была опубликована 24.04.2016 в 12:14.
    Метки: Cisco. VPN. Ошибка

    Ошибки Cisco VPN Client - Ошибки во время выполнения

    Solvusoft: Золотой сертификат Microsoft Компания Solvusoft имеет репутацию лучшего в своем классе независимого поставщика программного обеспечения,

    и признается корпорацией Microsoft в качестве ведущего независимого поставщика программного обеспечения, с высшим уровнем компетенции и качества. Близкие взаимоотношения компании Solvusoft с корпорацией Microsoft в качестве золотого партнера позволяют нам предлагать лучшие в своем классе решения, оптимизированные для работы с операционной системой Windows.

    Как достигается золотой уровень компетенции?

    Чтобы обеспечивать золотой уровень компетенции, компания Solvusoft производит независимый анализ,добиваясь высокого уровня опыта в работе с программным обеспечением, успешного обслуживания клиентов и первоклассной потребительской ценности. В качестве независимого разработчика ПО Solvusoft обеспечивает высочайший уровень удовлетворенности клиентов, предлагая программное обеспечение высшего класса и сервисные решения, постоянно проходящие строгие проверку и отбор со стороны корпорации Microsoft.

    НАЖМИТЕ для верификации статуса Solvusoft как золотого партнера корпорации Microsoft на сайте Microsoft Pinpoint >>

    Cisco vpn client, настройка cisco vpn client, настройка cisco vpn

    Cisco vpn client, настройка cisco vpn client, настройка cisco vpn. РОСТ ЧИСЛА НАДОМНЫХ РАБОТНИКОВ И ВОЗРОСШАЯ МОБИЛЬНОСТЬ ПОЛЬЗОВАТЕЛЕЙ ВСЕ ЧАЩЕ СТАВЯТ ПЕРЕД НЕБОЛЬШИМИ КОМПАНИЯ ЗАДАЧУ ОБЕСПЕЧЕНИЯ УДАЛЕННОГО ДОСТУПА К КОРПОРАТИВНЫМ РЕСУРСАМ (REMOTE ACCESS VPN). А ПОВСЕМЕСТНОЕ РАСПРОСТРАНЕНИЕ НЕДОРОГОГО ШИРОКОПОЛОСНОГО ДОСТУПА ПО ТЕХНОЛОГИЯМ DSL, WIFI И ETHERNET СОЗДАЕТ ВСЕ УСЛОВИЯ ДЛЯ ТОГО, ЧТОБЫ УДАЛЕННЫЙ ДОСТУП СТАЛ РЕАЛЬНОСТЬЮ http://www.lanberry.ru/cisco/nastroika-cisco-vpn-client http://www.lanberry.ru/@@site-logo/logo.png

    Cisco vpn client, настройка cisco vpn client, настройка cisco vpn.

    РОСТ ЧИСЛА НАДОМНЫХ РАБОТНИКОВ И ВОЗРОСШАЯ МОБИЛЬНОСТЬ ПОЛЬЗОВАТЕЛЕЙ ВСЕ ЧАЩЕ СТАВЯТ ПЕРЕД НЕБОЛЬШИМИ КОМПАНИЯ ЗАДАЧУ ОБЕСПЕЧЕНИЯ УДАЛЕННОГО ДОСТУПА К КОРПОРАТИВНЫМ РЕСУРСАМ (REMOTE ACCESS VPN). А ПОВСЕМЕСТНОЕ РАСПРОСТРАНЕНИЕ НЕДОРОГОГО ШИРОКОПОЛОСНОГО ДОСТУПА ПО ТЕХНОЛОГИЯМ DSL, WIFI И ETHERNET СОЗДАЕТ ВСЕ УСЛОВИЯ ДЛЯ ТОГО, ЧТОБЫ УДАЛЕННЫЙ ДОСТУП СТАЛ РЕАЛЬНОСТЬЮ

    Cisco VPN Client

    Cisco VPN Client - программное обеспечение, устанавливаемое на персональный компьютер и предназначенное для создания IPSec-туннеля с любым сервером Cisco Easy VPN, в качестве которого могут выступать Cisco PIX, Cisco VPN 3000 Concentrator, Cisco ASA 5500 и Cisco IOS.

    Клиент VPN от компании Cisco поддерживает двухфакторную аутентификацию пользователей с помощью USB-токенов или смарткарт Aladdin eToken.

    Основные возможности и характеристики Cisco VPN Client:
    • Cisco VPN Client поддерживает все операционные системы Windows, Linux, Solaris и MacOS;
    • поддержка протоколов IPSec ESP, PPTP, L2TP, L2TP/IPSec, NAT Traversal IPSec, IPSec/TCP, IPSec/UDP;
    • поддержка DES, 3DES и AES с MD5 и SHA;
    • поддержка токенов Aladdin, ActiveCard, Schlumberger, Gemplus, Datakey и других через MS CAPI;
    • поддержка аутентификации XAUTH, LDAP, RADIUS с поддержкой для Active Directory, Kerberos, RSA SecurID, MS-CHAPv2, x509v3;
    • В Cisco VPN Client отсутствуют конфликты с клиентом Microsoft L2TP/IPSec;
    • поддержка протокола Simple Certificate Enrollment Protocol (SCEP);
    • поддержка IKE;
    • Cisco VPN Client сжимает передаваемые данные;
    • автоматическое обновление до новой версии Cisco VPN Client;
    • программный интерфейс API для контроля функционирования Cisco VPN Client из других приложений;
    • балансировка нагрузки и поддержка резервных VPN-шлюзов;
    • централизованное управление с помощью политик (включая списки резервных VPN-шлюзов);
    • интеграция Cisco VPN Client с Cisco Security Agent, Sygate, ZoneAlarm.
    cisco vpn client

    Цель состоит в том, чтобы обеспечить одинаковый уровень производительности и безопасности при работе с критически важными приложениями для всех сотрудников компании, независимо от того, находятся они в головном офисе или в филиалах, работают дома или в пути. В первую очередь, это требует обеспечения защиты данных, передаваемых по открытым каналам связи (например, через интернет). Сохранение конфиденциальности и целостности данных является обязательным элементом современных бизнес-приложений. Это требование достигается за счет стратегии Cisco Secure Connectivity System. которая, используя механизмы шифрования и аутентификации, одинаково эффективно защищает данные, голос и видео, передаваемые как по проводным, так и по беспроводным соединениям. Составной частью Secure Connectivity System являются такие технологии, как IPSec. EasyVPN. SSL. SSH. GRE и MPLS .

    Работу любой технологии, обеспечивающей защищенную передачу данных через неподконтрольную, а потому всегда потенциально опасную среду, можно условно разделить на две фазы. Первая фаза представляет собой установление соединения с обязательной проверкой подлинности взаимодействующих сторон (аутентификацию), применением политик безопасности (авторизацию) и установлением ключей шифрования для второй фазы. На второй фазе происходит непосредственно передача зашифрованных ранее установленными ключами данных, целостность (неизменность) которых обязательно проверяется при приеме.

    Первая фаза на примере технологии IPSec Easy VPN

    Перед тем, как пользователь сможет передавать зашифрованные данные в удаленную сеть, он должен осуществить процесс подключения. При этом происходит процедура аутентификации, во время которой пользователь должен подтвердить, что он именно тот, за кого себя выдает, и действительно имеет право произвести удаленное подключение. Аналогом этого процесса из реальной жизни является предъявление паспорта сотруднику банка. В IPSec VPN сетях для аутентификации удаленных пользователей может использоваться заранее заданное на клиентских устройствах и сервере секретное значение (ключ), цифровые сертификаты формата x.509, основанные на использовании технологий цифровой подписи, групповые и персональные имена пользователей и пароли, а так же различные комбинации этих методов.

    В настоящее время наиболее защищенным способом аутентификации является использование цифровых сертификатов. Аутентификация с использованием цифровых сертификатов не подвержена наиболее совершенному методу атак «man in the middle» (MITM. человек посередине). Суть этого метода состоит в том, что злоумышленник некоторым образом получает возможность пропустить через себя весь трафик между двумя взаимодействующими устройствами. При этом он выступает в качестве своеобразного proxy-сервера, который может выборочно пропускать через себя трафик легитимных устройств, подменяя часть данных на собственные. Из перечисленных методов только использование цифровых сертификатов позволяет полностью исключить возможность успешного проведения подобного типа атак. Но для того, чтобы использовать цифровые сертификаты, в сети обязательно должен присутствовать сервер цифровых сертификатов (Certification Authority).

    Операционная система Cisco IOS. под управлением которой работают все маршрутизаторы Cisco, содержит встроенный сервер цифровых сертификатов, предназначенный для использования совместно с технологиями IPSec VPN и SSL VPN.

    Remote Access VPN

    Представь себе следующую ситуацию. Тебе нужно обеспечить удаленный доступ к корпоративной сети нескольким десяткам сотрудников. Ты можешь использовать для этого технологию шифрованных VPN. Но чем больше сотрудников будет пользоваться удаленным доступом, тем больше компьютеров со всеми детальными политиками безопасности нужно будет настроить. Как же избежать головной боли с настройкой и поддержкой столь большого числа клиентских устройств? А если не все сотрудники используют ноутбуки? И кто-то из надомных сотрудников захочет получать доступ со своего домашнего компьютера, который он настраивает сам. Сможет ли он так же аккуратно и правильно настроить свой компьютер для удаленного доступа к корпоративной сети, как это сделает системный администратор? Ответом на эти вопросы является использование технологии Cisco Easy VPN. Ее основное преимущество - использование «глупых» клиентов, конфигурирование которых сведено к минимуму.

    Когда пользователю уже выдан цифровой сертификат, для создания VPN-соединения в Cisco Easy VPN Client достаточно настроить IP-адрес маршрутизатора компании, подключенного к интернету. Никаких настроек, связанных с использованием алгоритмов шифрования, аутентификации, хеширования для обеспечения целостности, распространения ключей шифрования для протоколов второй фазы и т.п. производить не нужно. Причем для установления VPN-соединения клиентским устройствам совсем не обязательно иметь публичные IP-адреса. За счет передачи IPSec трафика поверх протокола TCP или UDP пользователи могут находиться за устройствами, осуществляющими трансляцию адресов с использованием технологий NAT/PAT.

    При выдаче сертификата пользователю, ему автоматически передается корневой сертификат сервера цифровых сертификатов, содержащий только публичный ключ. Он будет использоваться при подключении перед аутентификацией, для проверки подлинности сервера, к которому производится подключение, и исключения атаки MITM.

    Итак, есть задача — в короткие сроки развернуть для сотрудников компании защищенную по последнему слову техники сеть удаленного доступа. При этом нужно постараться избежать использования дополнительных компонентов, усложняющих и удорожающих решение.

    Для этого возьмем маршрутизатор Cisco 857W. Помимо всех функций маршрутизации и обеспечения безопасности, у этого устройства есть еще и встроенная беспроводная точка доступа и RADIUS-сервер. Наличие RADIUS-сервера позволяет защитить небольшую сеть на несколько точек доступа в соответствии с последними рекомендациями WiFi-форума по защите корпоративных беспроводных сетей.

    Синхронизация времени по протоколу NTP

    Для нормальной работы инфраструктуры PKI очень важно, чтобы на всех взаимодействующих устройствах было установлено точное время и дата. В цифровом сертификате формата x.509 присутствуют поля с явным указанием его срока действия. В случае сильного расхождения времени на двух устройствах при проведении процедуры аутентификации одно из них решит, что срок действия сертификата другого устройства уже истек или еще не наступил. При этом сертификат считается недействительным, и успешное завершение процедуры аутентификации становится невозможным.

    На любых устройствах, работающих под управлением OC Cisco IOS. точное время можно устанавливать при помощи протокола NTP (Network Time Protocol). Рекомендуется использовать NTP-серверы, имеющие наивысший Stratum1. Это означает, что NTP-сервер напрямую подключен к источнику точного времени, такому как атомные часы или GPS приемник. В свою очередь, Stratum2 получает точное время от Stratum1 и т.д. Если у тебя нет подконтрольного NTP-сервера, рекомендуется настроить для синхронизации сразу несколько внешних серверов. На любом NTP-сервере может произойти сбой, в результате которого он начнет распространять значительно отличающееся от реального время. Если на маршрутизаторе настроено несколько NTP-серверов, алгоритм тут же определит неожиданно большую разницу между получаемыми значениями и не будет использовать вышедший из строя сервер.

    !указано отличие московского времени от времени по Гринвичу
    clock timezone Moscow 3
    !алгоритм перевода часов для соответствия российскому летнему времени
    clock summer-time Moscow recurring last Sun Mar 3:00 last Sun Oct 4:00
    !не обязательно использовать приведенные ниже серверы
    !список публичных серверов Stratum 1 и 2 найдешь на сайте www.ntp.org
    ntp server 195.68.135.5
    ntp server 193.79.237.14
    ntp server 195.2.64.5
    ntp server 193.190.230.65

    Сервер сертификатов Cisco IOS

    Сервер сертификатов Cisco IOS Certificate Server внедрен в программное обеспечение Cisco IOS и дает маршрутизатору возможность действовать в сети в качестве центра сертификации (выпускать и отзывать цифровые сертификаты). Традиционно, генерирование криптографической информации и управление ею — непростая задача, по мере роста количества VPN. Сервер сертификатов Cisco IOS решает эти проблемы при помощи масштабируемого и несложного в управлении центра сертификации, который встроен в ту же аппаратуру поддержки IPSec VPN. Программное обеспечение Cisco IOS также поддерживает встроенные клиентские функции PKI, которые взаимодействуют с сервером сертификатов и с центрами сертификатов сторонних производителей.

    Возможности PKI клиента:
    • поддержка локальных списков ACL для принятия или отклонения сертификатов на основании полей сертификации;
    • интеграция с AAA для авторизации сертификатов на базе имени пользователя и других атрибутов;
    • поддержка онлайнового протокола статуса сертификата (Online Certificate Status Protocol, OCSP);
    • поддержка списков отзыва сертификатов и автоматического переиздания.
    Настройка сервера цифровых сертификатов на маршрутизаторе

    Встроенный в Cisco IOS Сервер цифровых сертификатов имеет богатые возможности по настройке. Приведем минимально необходимое количество команд для создания работоспособной конфигурации.

    !задай имя для сервера цифровых сертификатов
    crypto pki server certsrv
    database level names
    issuer-name CN=certsrv, OU=client-group-1, O=Cisco Systems
    grant auto
    !настройку параметров можно производить только в выключенном состоянии, после завершения настройки сервер нужно перевести в рабочее состояние
    no shutdown

    После этого будет сгенерирована ключевая пара для корневого сертификата сервера. При помощи ее частного ключа в дальнейшем будут подписываться все выдаваемые сервером сертификаты.

    Команда grant auto позволяет автоматически выдавать сертификаты на запросы пользователей, что значительно упрощает процедуру выдачи сертификатов большому числу клиентов. Если канал между клиентом и сервером цифровых сертификатов во время выписки защищен, то сохраняется должный уровень безопасности. Например, выдачу сертификатов онлайн можно разрешить только пользователям внутри корпоративной сети.

    Технология настройки Cisco VPN client

    Технология Cisco Easy VPN упрощает администрирование и управление сетями VPN, которые связывают различные узлы сети между собой, за счет активного продвижения новых политик безопасности из головного узла в сети на удаленные площадки. Для простоты конфигурации и высокой масштабируемости в решении Easy VPN применяется технология «проталкивания политики» (policy-push), но при этом сохраняется широкий спектр настроек и контроль над соблюдением политики.

    Сервер Easy VPN, сконфигурированный в центральном офисе компании, передает политики безопасности на удаленные устройства VPN, обеспечивая реализацию на таких соединениях действующих политик еще до установки соединения.

    7 преимуществ Easy VPN
    1. Easy VPN Server и Easy МЗТ Client поддерживается на маршрутизаторах с интеграцией сервисов, VPN-концентраторах, межсетевых экранах Cisco PIX и многофункциональных защитных устройствах Cisco ASA.
    2. Клиентское программное обеспечение Cisco VPN Client можно инсталлировать без дополнительных затрат на компьютерах PC, Mac и в системах UNIX, для удаленного доступа к VPN-маршрутизатору. Поскольку одна и та же технология (Easy VPN ) используется на аппаратуре у клиента (CPE) и программном обеспечении, общая стоимость владения снижается за счет упрощения и унификации в обслуживании, мониторинге и сервисов AAA.
    3. В Easy VPN предусмотрены опции локальной (на базе маршрутизаторов) и централизованной аутентификации RADIUS. Аутентификацию на базе стандарта 802.1x также можно использовать для аутентификации хостов в каждом местоположении CPE.
    4. Easy VPN предлагает цифровые сертификаты, повышая уровень безопасности по сравнению с preshared keys.
    5. Балансировка нагрузки для нескольких находящихся на центральной площадке концентраторов Easy VPN автоматически распределяет нагрузку между несколькими серверами Easy VPN. Принудительная передача политик с резервных концентраторов на CPE позволяет компаниям масштабировать решение без переконфигурации CPE.
    6. Easy VPN предлагает полнофункциональную интеграцию, включая динамическое назначение политики QoS, межсетевые экраны и IPS, раздельное туннелирование и Cisco Service Assurance Agent и NetFlow для мониторинга.
    7. Cisco SDM дает возможность на базе мастер-программы быстро развернуть Easy VPN совместно с сервисами AAA и межсетевого экрана, а также возможность графического мониторинга удаленных клиентов Easy VPN в реальном времени.
    Cisco Easy VPN Client

    Программное обеспечение Cisco VPN Client предназначено для удаленного подключения к корпоративной сети с помощью VPN-туннеля. Cisco VPN Client не требует почти никакой настройки со стороны пользователя. Все параметры соединения и политики безопасности передаются клиенту во время подключения к шлюзу доступа. Cisco VPN Client бесплатно доступен всем пользователям продуктов Cisco со встроенной функциональностью Easy VPN-сервера. К таким продуктам относятся маршрутизаторы с интеграцией сервисов, VPN-концентраторы, межсетевые экраны Cisco PIX и многофункциональные защитные устройства Cisco ASA .

    Настройка Cisco VPN Client

    Для настройки VPN-клиента достаточно создать соединение, указав IP-адрес сервера. Нужно использовать IP-адрес подключенного к интернету интерфейса маршрутизатора. На этот интерфейс был назначен crypto map при настройке Easy VPN-сервера.

    Чтобы начать процедуру получения цифрового сертификата в меню VPN-клиента, нужно выбрать Certificates -> Enroll. Для выдачи сертификата пользователю должна существовать IP-достижимость между компьютером и интерфейсом локальной сети маршрутизатора.

    CA URL: http://192.168.0.1:80/cgi-bin/pkiclient.exe
    CA Domain: router.homelinux.org

    Обязательно нужно указать домен, даже если он не настроен на маршрутизаторе. Без указания домена выдача сертификата невозможна!

    Name[CN]: Dmitry Ryzhavsky (имя пользователя)
    Department [OU]: client-group-1 (должен совпадать crypto isakmp client configuration group, задаваемой при настройке Easy VPN-сервера)

    При выдаче сертификата пользователю в VPN-клиенте также будет передан корневой сертификат CA, содержащий публичный ключ сервера цифровых сертификатов. С его помощью при установлении соединения будет проверяться подлинность сертификата Easy VPN-сервера. За счет этого становится возможным исключение атаки типа MITM.

    Если обеспечить доступ клиента по IP к серверу цифровых сертификатов невозможно, выписку сертификатов пользователям можно осуществлять в ручном режиме. При этом сгенерированный клиентом запрос на получение цифрового сертификата в виде двоичной последовательности вводится в командную строку сервера цифровых сертификатов. Выданный пользователю сертификат в том же виде импортируется в Cisco VPN Client.

    CISCO EASY VPN CLIENT — БЕСПЛАТНОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ, ДОСТУПНОЕ ДЛЯ СВОБОДНОЙ ЗАГРУЗКИ

    ПРИВЕДЕННЫЕ В ЭТОЙ СТАТЬЕ НАСТРОЙКИ МОГУТ БЫТЬ ИСПОЛЬЗОВАНЫ НА ЛЮБОМ МАРШРУТИЗАТОРЕ CISCO. НА КОТОРОМ УСТАНОВЛЕННОЕ ПО CISCO IOS СОДЕРЖИТ РАСШИРЕННЫЕ ФУНКЦИИ БЕЗОПАСНОСТИ.

    Shrew аналог Cisco VPN Client для windows 10

    Shrew аналог Cisco VPN Client для windows 10

    Программа Shrew является бесплатной альтернативной заменой Cisco VPN Client работающей и под Windows 10 и даже Linux. После обновления с windows 7 на window 10 столкнулся с проблемой - перестал работать cisco vpn client. Новой версии cisco vpn client для windows 10 нет и наверное небудет.

    Поэтому сразу понял, что нужно искать какой-то аналог программы и лучше бесплатный. Такой программой и явился проект Shrew, надо сказать, что shrew прекрасно работает как на x32 так и на x64 системах, да еще и ОС Linux.

    Ниже попробую описать подробный пример настройки программы Shrew по шагам.

    Пошагавая настройка shrew, аналога cisco vpn client в windows.

    1.Скачиваем Shrew с оффициального сайта, регистрация нетребуется. Я скачал последнюю версию shrew 2.2.2-release.

    2.Добавляем новое соединение (нажимаем Add).

    3.На вкладке "General" заполняем поля:

    "Host Name or IP address" - ip-адрес шлюза с которым устанавливается соединение IPSec.

    "Port" - номер порта для установки соединение IPSec.

    Все остальное оставляем по умолчанию.

    4.На вкладке "Client" оставляем все настройки по умолчанию.

    5.На вкладке "Name Resolution" тоже все оставляем по умолчанию.

    6.На вкладке "Authentication" выбираем Authentication method" - "Mutual PSK+Xauth", выставляется при методе аутентификации по IPSec Group ID или KeyID.

    6.1.На вкладке "Local Identity" выбираем "Identification Type" - "Key Identifier" и заполняем поле "Key ID String".

    6.2.На вкладке "Remote Identity"» оставляем все поумолчанию.

    6.3.На вкладке "Credentials" заполняем поле "Pre Shared Key".

    7.На вкладке "Phase 1" оставляем все настройки по умолчанию.

    8.На вкладке "Phase 2" так же оставляем все настройки по умолчанию.

    9.На вкладке "Policy" все настройки остаються по умолчанию.

    10.Нажимаем кнопку "save" для сохранения настроек.

    11.Соединяемся, нажимаем кнопку "Connect". И Заполняем данные для поднятия тунеля username и password. При положительном результате в логах появиться запись "tunel enabled".

    На этом все, при работе c shrew никаких существенных замечаний я необнаружел, все прекрасно работает. Комментируем, подписываемся ну и всем пока:)

    Самые популярные статьи:

    Настройка маршрутизатора и Cisco VPN клиента для доступа в Интернет

    Настройка маршрутизатора и Cisco VPN клиента для доступа в Интернет

    Перевод и дополнения HunSolo специально для CiscoLab.RU

    Этот документ описывает как настроить роутер, чтобы VPN клиент мог выходить через него в Интернет. Это называется “IPSEC на проволке”. Удаленные пользователи подключаются к роутеру при помощи Cisco VPN клиента и через него выходят в Интернет. Для того, чтобы выполнить данную задачу, на роутере настраивается политика трафика, которая заворачивает весь шифрованный трафик на Loopback интерфейс. Затем над этим трафиком выполняется PAT.

    Сетевая диаграмма показана на рисунке:

    <!--ecode1-->version 12.4
    !
    hostname VPN
    !
    !--- Разрешаем аутентификацию, авторизацию и аккаунтинг(AAA)
    aaa new-model
    !
    !--- Для того, чтобы использовать Xauth для аутентификации пользователей,
    !--- подключаем команды аутентификации
    aaa authentication login userauthen local

    ---Для того, чтобы использовать групповую авторизацию включаем команды авторизации
    aaa authorization network groupauthor local
    !
    aaa session-id common
    !
    !--- Для локальной аутентификации IPSec пользователя создаем пользователя с паролем
    username user password 0 cisco
    !

    --- Создает ассоциации безопасности и политику ISAKMP для IKE Фазы 1
    crypto isakmp policy 3
    encr 3des
    authentication pre-share
    group 2


    !--- Создаем группу которая используется для указания адресов серверов WINS и DNS клиентам VPN
    !--- а также заведомо определяем ключ для IPSEC аутентификации

    crypto isakmp client configuration group vpnclient
    key cisco123
    dns 10.10.10.10
    wins 10.10.10.20
    domain cisco.com
    pool ippool
    !

    --- Создаем политику IKE Фазы 2 Policy для непосредственно шифрования.
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    !
    !--- Создаем динамическую карту и применяем правила преобразования созданные выше
    crypto dynamic-map dynmap 10
    set transform-set myset
    reverse-route
    !


    !--- Создаем непосредственно карту шифрования и привязываем список AAA с ней
    crypto map clientmap client authentication list userauthen
    crypto map clientmap isakmp authorization list groupauthor
    crypto map clientmap client configuration address respond
    crypto map clientmap 10 ipsec-isakmp dynamic dynmap
    !
    !

    --- Создаем loopback интерфейс для VPN трафика
    .interface Loopback0
    ip address 10.11.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Ethernet0/0
    ip address 10.10.10.1 255.255.255.0
    half-duplex
    ip nat inside


    !--- Применяем карту шифрования на внешний интерфейс и ставим политику маршрутизации
    interface FastEthernet1/0
    ip address 172.16.1.1 255.255.255.0
    ip nat outside
    ip virtual-reassembly
    ip policy route-map VPN-Client
    duplex auto
    speed auto
    crypto map clientmap
    !

    --- Создаем пул IP адресов назначаемых VPN клиентам
    ip local pool ippool 192.168.1.1 192.168.1.2


    ip route 10.0.0.0 255.255.255.0 172.16.1.2

    --- Включаем (NAT) над трафиком попадающим в лист доступа 101
    ip nat inside source list 101 interface FastEthernet1/0 overload
    !

    --- Лист доступа используется для указания трафика, над которым выполняется преобразование адресов
    access-list 101 permit ip any any


    !--- Интересующий трафик который необходимо заворачивать на Loopback
    access-list 144 permit ip host 192.168.1.0 0.0.0.255 any


    !--- Настраиваем политику маршрутизации, которая ловит интересующий трафик (access list 144)
    !--- и маршрутизирует его на loopback интерфейс.
    route-map VPN-Client permit 10
    match ip address 144
    set interface Loopback0
    !
    !
    end<!--code2-->

    Настройка VPN Client

    Запустите Cisco VPN Client. Выберите Connection Entries > New

    Введите имя и описание соединения, IP адрес внешнего интерфейса маршрутизатора, имя и пароль для VPN группы, и нажмите Save

    Нажмите на соедиение, которое вы только, что создали и нажмите Connect

    Когда выскочит окошко с приглашением ввести имя и пароль, введите имя пользователя и пароль

    Все VPN клиент подсоединен к роутеру в корпоративной сети

    Можно выбрать опцию Status > Statistics чтобы посмотреть статистику передачи данных по туннелю