Софт-Портал

Эксел

Рейтинг: 4.1/5.0 (26 проголосовавших)

Категория: Windows

Описание

Функции Excel

Функции Excel.Функция И(), ИЛИ()

На прошлом уроке "Функции Excel. Функция ЕСЛИ " была рассмотрена работа со встроенной функцией ЕСЛИ(). Все бы хорошо, но возникают такие ситуации, и довольно часто, когда вложенностью условия в условие не обойтись. Например, элементарно необходимо проверить следующее: 1 больше или равно x и x меньше или равно 5. Реализовать такое условие несколькими ЕСЛИ довольно громоздко и проблематично, а в некоторых ситуациях - вообще невозможно. Для расширения функционала ЕСЛИ и облегчения составления формул с условием, в Excel имеются еще пара полезных функции - И() и ИЛИ().

Функция И()

Функция И() используется тогда, когда необходимо проверить несколько условий следующим образом - Условие 1ИУсловие 2. При этом все условия должны быть истинными. Результатом работы данной функции является ИСТИНА или ЛОЖЬ (TRUE / FALSE). Пример: ЕСЛИ а = b И а=с ТОГДА значение 1 ИНАЧЕ значение 2.
Как видно из примера, значение 1 будет только в том случае, если все условия верны.

Функция ИЛИ()

Функция ИЛИ() используется тогда, когда необходимо проверить несколько условий следующим образом - Условие 1ИЛИУсловие 2. Результат функции будет истинным, если хотя бы одно из условий истинно. Пример: ЕСЛИ а = b ИЛИ а=с ТОГДА значение 1 ИНАЧЕ значение 2.

Синтаксис функций И() и ИЛИ() одинаков: Функция(Условие 1; Условие 2; Условие 3 и до 30-ти условий). Результат ИСТИНА или ЛОЖЬ.

Примеры использования функции И и ИЛИ

Все вышесказанное сложно к пониманию и относится к разделу Мат. логики и Дискретной математики. Попробую это все изложить на понятном языке. Разберем несколько примеров. Скажу сразу, все примеры будут с использованием функции ЕСЛИ.

Пример 1.
Столбец А, начиная с первой строки, содержит 56, 55, 88, 6, 74. Столбец В - 52, 55, 88, 4, 25. Столбец С - 53, 55, 88, 6, 25. С помощью функций ЕСЛИ и И необходимо определить строки, значения которых равны следующим образом А=В и В=С.

Переходим в ячейку D1 и с помощью мастера функций вводим следующее

Формула будет выглядеть так: “ =ЕСЛИ(И(A1=B1;B1=C1);"Все значения равны";"Значения не равны") “

Теперь пример на функцию ИЛИ. Те же столбцы, те же значения, условие следующее: с помощью функций ЕСЛИ и ИЛИ необходимо определить строки, в которых есть совпадающие значения А=В или В=С или А=С.

Мастер функций выглядит так:

Формула: “ =ЕСЛИ(ИЛИ(A1=B1;B1=C1;A1=C1);"Есть равные значения";"Нет равных значений")”

Вот и все. Функции не сложны. Применяйте их там, где встречаются условия и произносится И и ИЛИ. Так же, всеми выше перечисленными функциями можно сравнивать текстовые значения.

И напоследок рассмотрим еще один пример с функцией И и ИЛИ из реальной жизни.

В таблицу занесены процент выполнения заданий, необходимо проценты перевести в пятибалльную систему следующим образом:

Таблица следующего вида:

Составим формулу следующего вида:

Пища для разума Почему значения указаны в вещественном виде т.е. 0,41, 0,76, можете прочитать в уроке «Формат данных в Excel »!?

Результат работы формулы:

П.С.. Если есть варианты сократить формулу(а они есть) пишите в комментариях. А пока – пока

Другие статьи, обзоры программ, новости

Функция ЕСЛИ в Excel с примерами

Функция ЕСЛИ в Excel с примерами

Сегодня мы рассмотрим функцию ЕСЛИ .

Функция ЕСЛИ часто используется в Excel для решения многих задач. Знать ее очень полезно. В данной статье мы попробуем рассказать про ее работу на простых примерах, достаточно один раз разобраться с конструкцией функцией ЕСЛИ и вы сможете применять ее и в самых сложных вариантах.

Функция ЕСЛИ проверяет, выполняется ли условие, и возвращает одно значение, если оно выполняется, и другое значение, если нет.

Синтаксис функции ЕСЛИ очень простой:

ЕСЛИ( лог_выражение ; [ значение_если_истина ]; [ значение_если_ложь ])

лог_выражение – это любое значение или выражение, которое при вычислении дает значение ИСТИНА или ЛОЖЬ.

Что это значит? Выражение при вычислении дает значение ИСТИНА если это выражение верно.

В этой части необходимо проверить на соответствие выражения.

=ЕСЛИ (А1=10 ; [значение_если_истина]; [значение_если_ложь]) - если А1 равно 10, то выражение А1=10 даст значение ИСТИНА, а если не равно 10, то ЛОЖЬ

=ЕСЛИ( А1>30 ; [значение_если_истина]; [значение_если_ложь]) - если в ячейки А1 число больше 30, то А1>30 вернет ИСТИНА, а если меньше, то ЛОЖЬ

=ЕСЛИ( С1=”Да” ; [значение_если_истина]; [значение_если_ложь]) - если в ячейки C1 содержится слово “Да” то выражение вернет значение ИСТИНА, а если нет, то С1=”Да” вернет ЛОЖЬ

Надеюсь с этим понятно, поехали дальше. Рассмотрим следующие компоненты функции ЕСЛИ

=ЕСЛИ( лог_выражение ; [ значение_если_истина ]; [ значение_если_ложь ])

значение_если_истина. значение_если_ложь – как видно из их названия, это то что необходимо сделать в зависимости от того, что вернул лог выражения. ИСТИНА и ЛОЖЬ

Пример использования функции ЕСЛИ в Excel

Рассмотрим использование функции ЕСЛИ на практическом примере. У нас есть таблица заказов, которую мы использовали при рассмотрении работы функции ВПР. Нам необходимо заполнить столбец по заказам Ведер (ошибочно на картинке указано «Заказы Cтолов»), то есть необходимо выбрать только заказы с Ведрами. Это можно сделать различными способами, но мы с вами будет использовать функцию ЕСЛИ, чтобы показать ее работу на примере. (см.рисунок)

Для решения поставленной задачи напишем формулу с использованием функции ЕСЛИ

=ЕСЛИ(A3="Ведро";D3; «-») и нажмем Enter

Как вы смогли заметить аргументы функции ЕСЛИ разделены точкой с запятой.

Итак, первый аргумент ( лог выражения ) A3="Ведро" проверяет содержится ли в ячейке А3 слово «Ведро», если содержится, то выполняется второй аргумент функции ЕСЛИ ( значение_если_истина ), в нашем случае это D3 (т.е стоимость заказа), если в ячейка А3 не равна слову «Ведро», то выполняется третий аргумент функции ЕСЛИ ( значение_если_ложь ), в нашем случае это «-» (т.е будет написано тире).

Таким образом, в ячейки E3 появится значение D3, т.е число 240.

Далее необходимо протянуть формулу вниз для остальных значений. Для этого необходимо выделить ячейку Е3 и потянуть вниз за нижний правый угол (смотрите рисунок 3)

Итоговый результат работы функции ЕСЛИ вы можете посмотреть на рисунке 4. Функцию ЕСЛИ можно использовать в очень многих ситуациях. Находить ошибки, находить уникальные значения в списке, использовать многократные проверки на выполнение условий. Разбор всех этих приемов Excel ждет вас впереди.

Если статья была Вам полезна, то будем благодарны, если Вы поделитесь ей со своими друзьями с помощью кнопок расположенных ниже.

Спасибо за внимание.

Спасибо за лайк!

28.09.2015 в 5:38 пп

Скажите пожалуйста, как вбить формулу:

— есть несколько таблиц (на одном листе), в графе «Исполнитель» указаны сотрудники, рядом графа с суммой. Можно ли задать формулу отдельно (в Основной таблице) по каждому сотруднику, что если Фамилия-Иванов стоит в графе «Исполнитель» то сумма рядом в его строке, плюсуется этому сотруднику в Основную таблицу. Если фамилия Петров — то сумма плюсуется Петрову в Основную таблицу.

29.09.2015 в 8:50 дп

Здравствуйте! можно добавить в основной таблице еще один дополнительный столбец и с помощью ВПР: sirexcel.ru/priemi-excel/. xcel_s_primerom/

Подтянуть данные по каждому сотруднику и потом просуммировать.

Если сотрудника нет, то ВПР выдаст ошибку, тогда равно текущей сумме, если ВПР не ошибка, то применяем снова ВПР, возвращаем сумму из таблице и суммируем с текущей

01.03.2015 в 7:57 дп

Доброе утро! Вот заготовка к и условия задачи. Никак не пойму в данной задаче что является истиной, что ложью. Подскажите пожалуйста.Задача: Поле "Оплата инструктору " вычислить по формуле (используйте функцию ЕСЛИ) исходя из тарифа- дежурство в зале-120 руб. за час, инд. занятия- 200 руб. за час, гр. занятия- 180 руб. за час.

Дата Инструктор Вид занятия Название тренировки Длительность тренировки Оплата инструктору

01.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

02.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

03.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

04.02.2015 Семенов П.П. Дежурство в зале Плавание 1

05.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

06.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

07.02.2015 Петров С.С. Дежурство в зале Аэробика 1,5

08.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

09.02.2015 Семенов П.П. Групповые занятия Плавание 1

10.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

11.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

12.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

13.02.2015 Сидоров М.М. Дежурство в зале Фитнес 1,5

14.02.2015 Семенов П.П. Групповые занятия Плавание 1

15.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

16.02.2015 Иванов. А.А. Индивидуальные занятия Йога 2

17.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

18.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

19.02.2015 Семенов П.П. Групповые занятия Плавание 1

20.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

21.02.2015 Иванов. А.А. Дежурство в зале Йога 2

22.02.2015 Петров С.С. Групповые занятия Аэробика 1,5

23.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

24.02.2015 Семенов П.П. Групповые занятия Плавание 1

25.02.2015 Котов К.К. Индивидуальные занятия Аквааэробика 1

26.02.2015 Сидоров М.М. Групповые занятия Фитнес 1,5

27.02.2015 Семенов П.П. Групповые занятия Плавание 1

28.02.2015 Котов К.К. Дежурство в зале Аквааэробика 1

28.02.2015 в 5:33 пп

Добрый день! Помогите пожалуйста решить задачу: рассчитать оплату инструктора по фитнесу используя функцию ЕСЛИ, если известны тарифы оплаты за 1 час: дежурство-120 руб, групповые занятия-180 руб, индивидуальные занятия-200 руб. Спасибо заранее

28.02.2015 в 6:00 пп

13.11.2014 в 6:19 пп

Чтобы не использовать CTRL + SHIFT + ВВОД, вместо K:K необходимо указать 1 — это номер столбца, он у вас один. Вот такую формулу и попробуйте на с другой книгой, я не помню будет она работать или нет.

Если не будет, то делаете новый лист, там в ячейке A1 прописываете формулу Ваша_другая_книга_A1 и протягиваете вниз и влево, то есть делаете копию данных, простой ссылкой. При открытии данные будут обновляться, Индекс используете ссылкой на эту страницу. Потом можете скрыть этот лист, чтобы не мешал.

12.11.2014 в 6:34 пп

Добрый вечер. У меня формула есть: =ЕСЛИ(B8=[Книга3]Лист1!$A$1;[Книга3]Лист1!$B$1;0)

Но у меня проблема заключается в следующем: вместо $A$1 и $B$1 мне нужно вставить диапозон. В итоге должно получиться следующее: лог_выражение после знака = должно выбирать из диапозона нужное значение, а ИСТИНА должна выбираться также из диапозона

13.11.2014 в 9:14 дп

Добрый день! Нужно либо делать много вложенных ЕСЛИ, либо использовать обычную ПОИСКПОЗ — смысл в том, что используя ПОИСКПОЗ функция будет пытаться найти искомое значение B8 в столбце диапазона (который вместо $A$1), если найдет, то выдаст номер строки (порядковый номер строки в указанном диапазоне), если не найдет, то будет ОШИБКА Н/Д. Далее используете один раз функцию ЕСЛИ. Если ошибка, например, пусто, если не ошибка, то используете функцию ИНДЕКС — =ИНДЕКС(диапазон_тот_что_вместо_$B$1;номер_найденной_строки_в_виде_формулы; столбец_1)

13.11.2014 в 12:09 пп

Не получается. Формула получилась следующая: =ИНДЕКС(J:K;ПОИСКПОЗ(B8;J:J;0);K:K)

В8 — артикул

Диапозон J:J — артикулы

Диапозон K:K — Цена

После написания формулы должна выходить цена, поиск по артикулу

ЧМ — Занимаемое командой место определяется по следующим критериям:

– наибольшее количество очков;

– лучшая разница забитых и пропущенных мячей;

– наибольшее количество забитых мячей.

ЧЕ — место в группе определяется по следующим критериям:

– большее количество турнирных очков, полученных командами во встречах друг с другом;

– лучшая разница забитых и пропущенных голов во встречах друг с другом;

– большее количество голов, забитых в матчах друг с другом;

т.е если на пример Бразилия и Мексика набрали одинаковое кол-во очков и у Бразилии разница мячей 5-3=2, а у Мексики — 3-3=0 и между собой сыграли Бразилия-Мексика 0-1, то в ЧМ выше будет Бразилия, а в ЧЕ — Мексика (личная встреча). ЧЕ — При равенстве очков у трёх команд вообще нужна таблица отдельно для них, а потом вернуться в основную (наверное коряво закрутил. ). Не могу никак это всё оформить.

29.05.2014 в 7:22 пп